Java Installer

Some versions of Blackboard Collaborate requires this... http://www.java.com/en/
Published on: 2016-05-23
See other articles in Student Applications.